Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Articles Articles
Filter by: Popular Clear All
  • Excelsior's Avatar
    06-12-2017, 11:29 AM
    As many of you probably know, I've been getting a P0171 code tripping my engine light. I was at Wal-Mart and happened to see an OBD-II code reader...
    13 replies | 249 view(s)
  • Excelsior's Avatar
    06-04-2017, 01:03 AM
    Okay, I posted a couple threads a few weeks ago, as I had my SES light on. After replacing my MAF sensor, fuel filter, and fuel pump, the light was...
    14 replies | 323 view(s)
  • porourke's Avatar
    06-10-2017, 06:09 PM
    OK have read several posts on here with 19 and 21 mm rear sway bar installs. I CAN'T FIND ONE ! I have called several junk yards telling them i'm...
    10 replies | 251 view(s)
  • 1ZX2's Avatar
    06-04-2017, 06:22 PM
    1ZX2 started a thread painted the pos in Project Worklogs
    it was looking really really bad so i painted it. got a bunch of bugs in it et so i painted it again. now have to paint it a third time.... at...
    9 replies | 209 view(s)
  • alexdkk's Avatar
    06-11-2017, 04:40 PM
    alexdkk started a thread F/I and MPG in Forced Induction
    Hey, I bought a zx2 recently and I was considering boosting it later on after I get the car's basic tune up and all that good stuff that comes with...
    8 replies | 207 view(s)
  • commodore9's Avatar
    06-17-2017, 03:25 PM
    commodore9 started a thread Clutch in Problems
    I was driving today and as I stopped at a light I pulled the car out of gear and the clutch stayed all the way pressed against the firewall. I...
    6 replies | 108 view(s)
  • DrewZX2's Avatar
    06-12-2017, 04:55 AM
    Hey guys so my AC compressor has finally given up. Air is warm, the clutch is not engaging, and there is no power loss when I turn the AC on. So...
    6 replies | 143 view(s)
  • 5Speed's Avatar
    05-29-2017, 04:39 PM
    I searched and couldn't find the write up on putting the Fan On High on a toggle switch. I did this mod like 10 years ago but then put it back to...
    2 replies | 396 view(s)
  • dmark101's Avatar
    06-05-2017, 08:12 PM
    Summer is almost here and it's time for one of the BEST SCPOC meets of the year! The Angeles Crest run is one of my favorites meets and is usually...
    4 replies | 166 view(s)
  • economichitman's Avatar
    06-20-2017, 04:18 PM
    So my AC works, usually, but the clutch cycles every 4 seconds, like clockwork. The pressure is right where it should be, it cycles exactly between...
    3 replies | 62 view(s)
  • S/Rsly's Avatar
    06-09-2017, 12:20 AM
    S/Rsly started a thread CV Axle Question in Problems
    It's been an interesting few days. Front end pass. side started clicking a few days ago, took it in to get a CV axle on that side as the boots were...
    3 replies | 139 view(s)
  • dimbonz's Avatar
    05-23-2017, 03:52 PM
    I havent seen a post or thread on replacement of the shifter bushing...new to zx2's need a walkthrough....1998 cool coupe
    2 replies | 163 view(s)
  • roundhouse's Avatar
    06-20-2017, 04:27 AM
    roundhouse started a thread rough idle in Problems
    ZX2 has rough idle with AC ON (SETTING AT IDLE) replace IAC valve NO DIFFERENCE NO LIGHTS ON OR CODES NO VACCUM LEAK THAT I know OF
    2 replies | 66 view(s)
  • evadfa's Avatar
    06-11-2017, 05:42 PM
    evadfa started a thread bad starter again? in Problems
    Good afternoon. I have a 2003 ZX2 automatic. Back in September of 2016 I was getting the intermittent no start. I thought it was the starter and...
    1 replies | 68 view(s)
  • porourke's Avatar
    06-10-2017, 06:10 PM
    porourke started a thread AC Delete ?? in Newbies
    want to remove the AC compressor but want to keep stock belt. Does anyone make an AC delete kit ??? Thanks.
    1 replies | 64 view(s)
  • 1ZX2's Avatar
    06-19-2017, 11:03 AM
    1ZX2 started a thread Tach Not Working in Problems
    ok, my tach would stop working then i'd tap on the plastic and it'd come back but it's getting progressively worse. now i have to push on it and it...
    1 replies | 43 view(s)
  • porourke's Avatar
    Yesterday, 05:11 PM
    Anyone install one of these ? $ 330.00, jst wondering if they work/last ???
    1 replies | 39 view(s)
  • commodore9's Avatar
    Yesterday, 02:39 PM
    commodore9 started a thread Smog in Zx2 General
    Need to get my car smogged in the next few weeks in California. I currently run an NGPO computer. Anybody know if this is the CA edition? Sent...
    1 replies | 28 view(s)
  • ontheedge's Avatar
    06-02-2017, 06:27 AM
    It's at Schoolcraft college in Livonia. I know 2 zx2's that will be there. Anyone else?
    0 replies | 149 view(s)
More Activity