Page 1 of 4 1234 LastLast
Results 1 to 15 of 55

Thread: TheEvilZX2

  1. #1

    Join Date
    Apr 2008
    Location
    Indian Head, MD
    Posts
    862
    Points
    32,906
    Bank
    0
    Total Points
    32,906
    Donate  
    Zomg you haz treasure for Christmas - 2000zx2chik 

    Exclamation TheEvilZX2

    *****Just noticed photobucket links are down. Pics can be found at imgur link below*****
    *** https://imgur.com/gallery/9CPMs ***

    So some of you that have been around here remember me and my red car. Basically life happened and it sat for almost two years. I put it back on the road two years ago and only drove it on weekends (when I wasn't riding the bike). Around this time last year around this time I took it back off the road and decided it was now or never. I've been sitting on multiple parts for years and finally put them to use. Although plenty of money was spent on new stuff over the last year.

    These are pretty much all of the pics I took over the whole process. I'll document whatever I can remember, anything else just ask!

    So, I bought an SPA manifold. Quickly found out the compressor housing on my t3/to4e wouldn't clear the block. Got the manifold angle cut a few degrees and was good to go!

    Making WG flange. Had to drill and tap the SPA manifold. Got a TiAL MVR, so its a bit big.






    Parts for first attempt at a downpipe, 3in SS. You'll see why that didn't work out later.




    Wiring the MTXL to the ECU and found out I had a tenant utilizing the car while it sat. Thankfully they didn't chew anything, poop everywhere or die inside the car.




    Car is getting rusty.




    Roof was looking like crap and had a tiny spot of surface rust starting to develop. Always wanted to go two tone red and black so I painted the roof black. I think it came out pretty decent....could definitely use a few more coats.




    I bought a CFM PCV "delete" and then went on an AN spree and did the PCV in -8AN with a check valve. The car isn't exactly on the road yet, and I'm already thinking about redoing this with a catch can.

    Clearanceistighthere






    -4AN oil feed

    Hard to see, but its fed from the port behind the coil pack.




    Downpipe v1 welded and wastegate flange welded. Test fit pictures with factory radiator in factory(ish) location. I did a little slotting on the upper mounts to push the top forward a hair. Also push/pull fans. Pusher in front of the turbo, puller in front of the trans.






    I opened up the tiny little hole that was for the SPA wastegate to this.

    Talked to a buddy of mine (hes got an 850ish whp EVO9) and showed him that pic. He said open it all the way up. I opened it up some more. Its not perfectly round, I know but the inside where ports 2 and 3 meet makes a beautiful transition up to the WG. I think this is sufficient.




    Everything mounted up. I got a silica high temp sleeve for the lower rad hose. Dangerously close to downpipe v1. Plus intercooler mounted and mockup charge piping ran.











    Only TIG welder I know is a local race shop owner. Had him TIG the new pipe. New windage tray gasket and oil pan tapped and welded with a 5/8ths fitting. 45deg 1/2in NPT to -12AN for oil drain.









    It was close...but theres a few issues. Cold side charge piping hangs a bit low at the intercooler as seen above. But each end is too long, they'll need a few inches cut off and a new bead rolled. Also, I dont really like where the MAF ended up, right next to the coil pack...I'm going to put some EMI/RF shielding around it and see what happens.





    Here's why downpipe v1 was a fail. Hits oil drain. D'oh!




    We bought my GF a beater zx2. 2002 ATX 200k on the clock and runs like a dream. Pictured between the turbo project and my silver beater.




    Only thing missing here is the downpipe, which hadn't been built yet. Radiator and fans need installed, coolant fiilled. New valve cover gasket. MAF wired up (PMAS HPX). Everything else is done...all the little stuff and details and whatever else I'm forgetting at the moment.





    Lengthy process to piece together and build downpipe v2. I'm not a welder and this has really crippled me during this process. I need to buy a welder and get crackin. Thankfully my buddy Ant was there to help make downpipe v2 a reality. This time its 2.5in still SS. No pics of it on the car.







    So the car is physically turboed. I bought a house and moved. The turbo car is still in my mom's driveway. Bought psychotuner's old engine from EnergyBlue.




    Funds being tight now that I've got a mortgage, it took a while to order the PRP package. Bought a used X4 somewhere along the way while I was turboing the car. PRP package comes in. I get familiar with the software, got my base tune loaded to the tuner. It wont flash the car. Got an error code. Contacted SCT...blah blah blah...had to send tuner in. That's where I'm at now. Waiting for the tuner. Then start tuning.

    Any questions?
    Last edited by TheEvilZX2; 07-17-2017 at 02:27 PM.

  2. #2

    Join Date
    Apr 2008
    Location
    McDonough, Georgia
    Posts
    5,520
    Points
    221,168
    Bank
    6,093,159
    Total Points
    6,314,327
    Donate  

    Default

    Wow nice work log man! Keep it up things are looking good. I like the two tone and thats a good spot for the transition. Cant wait to see it running.

  3. #3

    Join Date
    Mar 2014
    Location
    ohio
    Posts
    97
    Points
    21,435
    Bank
    0
    Total Points
    21,435
    Donate  

    Default

    sweet looks great

  4. #4

    Join Date
    May 2008
    Location
    Knoxvegas, TN
    Posts
    10,121
    Points
    80,333
    Bank
    201,650,001
    Total Points
    201,730,334
    Donate  
    Hope you enjoyed the "dragon" - zx2loon Me wubbz joo too!! - zx2loon Congrats bro!! - rascal get 'em done - GoT MiLF? Unicorn hood ornament! lol - rascal 
    Thanks for the rubber superman! wait... - Gitt24_84 For those rare times when you don't have sand in the vag... - Big Mizz 

    Default

    Good write up. Great pics. Got a twitch down in the the netherz. It's good to see it so close. Good luck and a lil Voodoo for The EvilZ. *Dances nekkid in the moonlight with a chicken sammich

    Your car needs some OukastRooster aesthetics
    2000 Black S/R (RIP), Iceman/CF hood/PnP ATX TB/K&N/MSD/PowderUDP-ODP/Esslinger cam gears/PS STS/SPI MTX/Fidanza/Stage2/Kamikaze/2.25"cat-less/Magnaflow/SCT(Pwned by Vit)/STB/21mmRSB/KYB/GC/Drag DR23
    Quote Originally Posted by mellowness65 View Post
    EXACTLY At night we could chant and sing in a circle around Doug's S/R and any others that may be there and burn a Cavalier as an offering to them
    Quote Originally Posted by Gitt24_84 View Post
    Nevermind, I'm fucking retarded
    Quote Originally Posted by ChillinZX View Post
    If you're talking about the slave cylinder "cock", you can play with that thing all day long and it will not get stiff.

  5. #5

    Join Date
    Apr 2008
    Location
    Indian Head, MD
    Posts
    862
    Points
    32,906
    Bank
    0
    Total Points
    32,906
    Donate  
    Zomg you haz treasure for Christmas - 2000zx2chik 

    Default

    Thanks everyone, its been a long time coming.

    Doug - outkastrooster's car was awesome. I loved the skulls everywhere. Is he still around?

    Sent from my SGH-M919 using Tapatalk

  6. #6

    Join Date
    Apr 2008
    Location
    Indian Head, MD
    Posts
    862
    Points
    32,906
    Bank
    0
    Total Points
    32,906
    Donate  
    Zomg you haz treasure for Christmas - 2000zx2chik 

    Default

    So I forgot to mention that the car actually started and idled (a little high) with the factory CIL2 tune. Held an AFR in the 15s when in open loop, then started searching for an idle when it went closed loop.

    I was just surprised it even ran. MAF, injectors and fuel pump have all been changed.

    Sent from my SGH-M919 using Tapatalk

  7. #7

    Join Date
    Apr 2008
    Location
    McDonough, Georgia
    Posts
    5,520
    Points
    221,168
    Bank
    6,093,159
    Total Points
    6,314,327
    Donate  

    Default

    What pump are you using?

  8. #8

    Join Date
    Apr 2008
    Location
    Indian Head, MD
    Posts
    862
    Points
    32,906
    Bank
    0
    Total Points
    32,906
    Donate  
    Zomg you haz treasure for Christmas - 2000zx2chik 

    Default

    TRE 255lph. They said it was for returnless fuel systems. It primes and the car runs with it untuned. I hope it lasts

    Sent from my SGH-M919 using Tapatalk

  9. #9

    Join Date
    Mar 2014
    Location
    Perth, ON Canadaland EH!!
    Posts
    198
    Points
    29,596
    Bank
    0
    Total Points
    29,596
    Donate  

    Default

    Nice, that should be enough to feed that boosted beast...lol.

    Do you have any pictures of the fuel pump installed?

  10. #10

    Join Date
    Apr 2008
    Location
    Indian Head, MD
    Posts
    862
    Points
    32,906
    Bank
    0
    Total Points
    32,906
    Donate  
    Zomg you haz treasure for Christmas - 2000zx2chik 

    Default

    Nope, i didn't take any. It was a direct swap aside from soldering two wires.

    Sent from my SGH-M919 using Tapatalk

  11. #11

    Join Date
    Apr 2008
    Location
    Indian Head, MD
    Posts
    862
    Points
    32,906
    Bank
    0
    Total Points
    32,906
    Donate  
    Zomg you haz treasure for Christmas - 2000zx2chik 

    Default

    http://treperformance.com/i-6321435-...2000-2008.html

    thats the pump im using. talked to the company and they suggested a different pump when i told them i was using it in a ford escort. when i asked to make sure it was for a returnless system they sent me the above link.

  12. #12

    Join Date
    Apr 2008
    Location
    McDonough, Georgia
    Posts
    5,520
    Points
    221,168
    Bank
    6,093,159
    Total Points
    6,314,327
    Donate  

    Default

    I like that its a direct swap. Dont know of anyone that has used that pump before. Whered you find out about it? Guess you'll be the guinea pig for tzx2 but that seems like an affordable pump that i may try at some point. I like their warrantee info as well.

  13. #13

    Join Date
    Apr 2008
    Location
    Indian Head, MD
    Posts
    862
    Points
    32,906
    Bank
    0
    Total Points
    32,906
    Donate  
    Zomg you haz treasure for Christmas - 2000zx2chik 

    Default

    Found it looking for returnless pumps online. Only found mention of a few mustang guys using it, everyone else on mustang forums and other forums I found with people asking about it said "use a walbro". but I can't find a single walbro pump that says its made for returnless. I even contacted a walbro rep....

    Like I said, the car started and idled, fuel pressure was spot on and steady....so its got that going for it. Its definitely quieter than any walbro I've heard. And it won't be ran hard until tuned properly. We'll see how it holds up from there. Also the price came down since last year, pretty sure I paid 115 or 120 for it.

    Sent from my SGH-M919 using Tapatalk

  14. #14

    Join Date
    Apr 2008
    Location
    Indian Head, MD
    Posts
    862
    Points
    32,906
    Bank
    0
    Total Points
    32,906
    Donate  
    Zomg you haz treasure for Christmas - 2000zx2chik 

    Default

    Got my X4 back from SCT on thursday, went out to try and get the base tune flashed. Damn thing still wont flash and still gives me an error. Going to have to call SCT again on monday. This sucks. I can datalog now using the X4 as a passthrough, which i couldnt do before, but still no tune on the car. Running my red cars stock CIL2.

    Started the car again just because I could. I'm definitely going to have to switch my PCV over to a catch can. The damn thing started howling, traced it down to excessive vacuum pulling air past the cam seals! That was money well wasted lol. Anyhow going to start looking for a catch can and redo the PCV system.

    Knowing that I'm going to need to contact SCT with the car availible on monday i rented a dolly and towed the damn thing down to my house to make things a bit easier on myself.

    My driveway is where its going to stay until it moves under its own power again.
    Attached Images Attached Images

  15. #15

    Join Date
    Apr 2008
    Location
    Indian Head, MD
    Posts
    862
    Points
    32,906
    Bank
    0
    Total Points
    32,906
    Donate  
    Zomg you haz treasure for Christmas - 2000zx2chik 

    Default

    Forgot to update this on Monday. Got home from work and called SCT. This time I plug the X4 in and get nothing but a blank white screen on it. Had to send back to SCT for a second time.

    This is rather frustrating. Definitely more issues than I had back in the day with Sniper, but i had no idea WTF i was doing then so I switched over to SCT for the turbo project.

    Assuming I can ever actually get this thing tuned and running I'd like to stick with SCT until I register the car as a Street Rod or Historic. Basically I need to pass emissions until then. Then at that point I'm thinking megasquirt.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •