Results 1 to 9 of 9

Thread: Charging issues

  1. #1

    Join Date
    May 2014
    Posts
    24
    Points
    4,653
    Bank
    0
    Total Points
    4,653
    Donate  

    Default Charging issues

    Today I replace my battery. Like an idiot I hooked it up backwards. Replaced the 100amp main fuse and a couple others. Now it won't charge. From the research I've done it's likely the voltage regulator. Is this the right one? http://m.ebay.com/itm/NEW-ALTERNATOR...-/371331875107
    2000 zx2 5 speed- stock

  2. #2

    Join Date
    May 2014
    Posts
    24
    Points
    4,653
    Bank
    0
    Total Points
    4,653
    Donate  

    Default

    Anyone? I know it says it is but the part number doesn't match the other motorcraft one I found.

  3. #3

    Join Date
    Jul 2008
    Location
    las vegas, so cal
    Posts
    21,216
    Points
    392,890
    Bank
    57,002,643
    Total Points
    57,395,532
    Donate  
    for the superman of the zx2 savers - daggit2005 Henry Ford < Dareall - SR2000 For the entertaining builds...constantly :-) - CJW For being a great member and friend to many. - CJW you sir are awarded the medal of awsome - daggit2005 
    Scammer Slaughering Medal of Honor - Hardline this is for the candy ive got from you with my purchases the past few years. - blue99fordzx2 For moving/locking my post when asked :) - blue99fordzx2 Thx for helping me get my car put back together. - X-Lr8 It's lunch time here. lolz - rascal 
    For dealing with dumbass n00bs. - RASCAL How much for the trim piece? LOL - RASCAL Absolute hero. I cannot imagine how helpful and kind a person Dareall is.  THANK YOU. - SoCalZx2Rob For doing my part out and finally getting the parts sold.  I owe it all to you.  Thanks Dareall.  I'll never forget it.  Thank god it's finally done.  XD - SoCalZx2Rob 

    Default

    this is why i really hate links. Can't help if I can't see what you are trying to show

    Attached Images Attached Images
    We're gonna ride the race cars
    We're gonna dance on fire

    Best sale thread ever !!

  4. #4

    Join Date
    Mar 2014
    Location
    Perth, ON Canadaland EH!!
    Posts
    198
    Points
    29,518
    Bank
    0
    Total Points
    29,518
    Donate  

    Default

    ^^^^ agreed

  5. #5

    Join Date
    May 2014
    Posts
    24
    Points
    4,653
    Bank
    0
    Total Points
    4,653
    Donate  

    Default

    You have to click the button in the corner. Screenshot_20170521-102931.png

  6. #6

    Join Date
    Mar 2014
    Location
    Perth, ON Canadaland EH!!
    Posts
    198
    Points
    29,518
    Bank
    0
    Total Points
    29,518
    Donate  

    Default

    That looks like the correct regulator from the picture.

  7. #7

    Join Date
    May 2014
    Posts
    24
    Points
    4,653
    Bank
    0
    Total Points
    4,653
    Donate  

    Default

    I went ahead and ordered it hopefully it's right.

  8. #8

    Join Date
    Nov 2014
    Posts
    296
    Points
    32,524
    Bank
    0
    Total Points
    32,524
    Donate  

    Default

    I installed a dual fast charge USB port that displays your charging voltage to keep an eye on the alternator health. Might want to do that to head off any charging issues.

    John

  9. #9

    Join Date
    May 2014
    Posts
    24
    Points
    4,653
    Bank
    0
    Total Points
    4,653
    Donate  

    Default

    I have an ultragauge that tells me voltage so that's taken care of. Just have to not be an idiot and hook the battery up wrong.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •